aboutsummaryrefslogtreecommitdiff
path: root/drive-sdk/deps/bzle/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drive-sdk/deps/bzle/src/CMakeLists.txt')
-rw-r--r--drive-sdk/deps/bzle/src/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/drive-sdk/deps/bzle/src/CMakeLists.txt b/drive-sdk/deps/bzle/src/CMakeLists.txt
new file mode 100644
index 0000000..a6f101a
--- /dev/null
+++ b/drive-sdk/deps/bzle/src/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Include the directory itself as a path to include directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+include(FindGLIB2)
+
+include_directories(
+ ${bzle_SOURCE_DIR}/include
+ ${GLIB2_INCLUDE_DIRS}
+)
+
+set(bzle_SOURCES
+att.c bluetooth.c btio.c gatt.c gattrib.c hci.c log.h log.c sdp.c utils.c uuid.c
+)
+
+add_library(bzle ${bzle_SOURCES})
+target_link_libraries(bzle
+ ${GLIB2_LIBRARIES}
+ )
+
+install(TARGETS bzle
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib
+)