aboutsummaryrefslogtreecommitdiff
path: root/drive-sdk/examples/vehicle-tool/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drive-sdk/examples/vehicle-tool/CMakeLists.txt')
-rwxr-xr-xdrive-sdk/examples/vehicle-tool/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/drive-sdk/examples/vehicle-tool/CMakeLists.txt b/drive-sdk/examples/vehicle-tool/CMakeLists.txt
new file mode 100755
index 0000000..58a67d3
--- /dev/null
+++ b/drive-sdk/examples/vehicle-tool/CMakeLists.txt
@@ -0,0 +1,31 @@
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+SET (CMAKE_C_FLAGS "")
+
+include(FindGLIB2)
+include(FindReadline)
+
+include_directories(${drivekit_SOURCE_DIR}/include
+ ${bzle_SOURCE_DIR}/include
+ ${GLIB2_INCLUDE_DIRS}
+ ${READLINE_INCLUDE_DIR}
+ )
+
+
+# Add sources
+set(vehicleTool_SOURCES
+ vehicle_tool.c
+ vehicle_cmd.c
+ display.c
+)
+
+add_executable(vehicle-tool ${vehicleTool_SOURCES})
+target_link_libraries(vehicle-tool
+ ankidrive
+ bzle
+ ${GLIB2_LIBRARIES}
+ ${READLINE_LIBRARY}
+)
+install(TARGETS vehicle-tool
+ RUNTIME DESTINATION bin
+)