aboutsummaryrefslogtreecommitdiff
path: root/drive-sdk/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drive-sdk/src/CMakeLists.txt')
-rw-r--r--drive-sdk/src/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/drive-sdk/src/CMakeLists.txt b/drive-sdk/src/CMakeLists.txt
new file mode 100644
index 0000000..b326665
--- /dev/null
+++ b/drive-sdk/src/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Include the directory itself as a path to include directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(drivekit_SOURCES
+ eir.c eir.h
+ anki_util.c
+ advertisement.c advertisement.h
+ uuid.c uuid.h
+ protocol.c protocol.h
+)
+
+
+# For a large number of source files you can create it in a simpler way
+# using file() function:
+# file(GLOB drivekit_SOURCES *.cpp)
+
+add_library(ankidrive ${drivekit_SOURCES})
+
+install(TARGETS ankidrive
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib
+)