aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..d211573
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,40 @@
+dnl $Id$
+
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(src/main.c)
+dnl Every other copy of the package version number gets its value from here
+AM_INIT_AUTOMAKE(tgeb, 0.3)
+
+dnl create a config.h file (Automake will add -DHAVE_CONFIG_H)
+AM_CONFIG_HEADER(config.h)
+
+AC_SUBST(VERSION)
+
+ISODATE=`date +%Y-%m-%d`
+AC_SUBST(ISODATE)
+
+AC_CANONICAL_HOST
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_RANLIB
+AC_PROG_INSTALL
+
+dnl Checks for libraries.
+AC_CHECK_LIB(z, inflate)
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(arpa/inet.h limits.h netdb.h netinet/in.h stddef.h stdlib.h string.h strings.h sys/socket.h unistd.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_STRUCT_TM
+
+dnl Checks for library functions.
+dnl AC_FUNC_MALLOC
+dnl AC_FUNC_REALLOC
+AC_CHECK_FUNCS(bzero gethostbyname memset mkdir socket strstr)
+
+AC_OUTPUT(Makefile include/Makefile lib/Makefile src/Makefile)