aboutsummaryrefslogtreecommitdiff
path: root/drive-sdk/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Sokolyuk <ds@doozer.de>2016-12-05 11:22:26 +0100
committerDimitri Sokolyuk <ds@doozer.de>2016-12-05 11:22:26 +0100
commit3c89fd52679c8ccebceb30294a4bd815b51ede19 (patch)
tree8fc9fb1763af5b0d6f5d5e76e0eb688c1771e9e5 /drive-sdk/test/CMakeLists.txt
parent58cf0a5b526a5afe6c8ee956aa32455dcf243586 (diff)
Import Drive SDK
Diffstat (limited to 'drive-sdk/test/CMakeLists.txt')
-rw-r--r--drive-sdk/test/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/drive-sdk/test/CMakeLists.txt b/drive-sdk/test/CMakeLists.txt
new file mode 100644
index 0000000..d1e1534
--- /dev/null
+++ b/drive-sdk/test/CMakeLists.txt
@@ -0,0 +1,18 @@
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+include_directories(${drivekit_SOURCE_DIR}/src
+ )
+
+# Add sources
+set(test_SOURCES greatest.h
+ anki_greatest.h
+ test_suite.c
+ test_ble_advertisement.c
+ test_vehicle_advertisement.c
+ test_protocol.c
+)
+
+add_executable(Test ${test_SOURCES})
+target_link_libraries(Test
+ ankidrive
+ )