aboutsummaryrefslogtreecommitdiff
path: root/drive-sdk/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drive-sdk/test/CMakeLists.txt')
-rw-r--r--drive-sdk/test/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/drive-sdk/test/CMakeLists.txt b/drive-sdk/test/CMakeLists.txt
new file mode 100644
index 0000000..d1e1534
--- /dev/null
+++ b/drive-sdk/test/CMakeLists.txt
@@ -0,0 +1,18 @@
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+include_directories(${drivekit_SOURCE_DIR}/src
+ )
+
+# Add sources
+set(test_SOURCES greatest.h
+ anki_greatest.h
+ test_suite.c
+ test_ble_advertisement.c
+ test_vehicle_advertisement.c
+ test_protocol.c
+)
+
+add_executable(Test ${test_SOURCES})
+target_link_libraries(Test
+ ankidrive
+ )